Launch Darkly

v0.0.4 published on Tuesday, Oct 4, 2022 by lbrlabs

Installation

The Pulumi Launch Darkly provider is available as a package in all Pulumi languages:

Provider Binary

The Launch Darkly provider binary is a third party binary. It can be installed using the pulumi plugin command.

pulumi plugin install resource launchdarkly <version>

Replace the version string with your desired version.

Setup

To provision resources with the Pulumi Launch Darkly provider, you need to have Launch Darkly credentials. Launch Darkly maintains documentation on how to create API keys here

Set environment variables

Once you have provisioned these credentials, you can set environment variables to provision resources in Grafana:

$ export LAUNCHDARKLY_ACCESS_TOKEN=<LAUNCHDARKLY_ACCESS_TOKEN>
$ export LAUNCHDARKLY_OAUTH_TOKEN=<LAUNCHDARKLY_OAUTH_TOKEN>
$ export LAUNCHDARKLY_ACCESS_TOKEN=<LAUNCHDARKLY_ACCESS_TOKEN>
$ export LAUNCHDARKLY_OAUTH_TOKEN=<LAUNCHDARKLY_OAUTH_TOKEN>
> $env:LAUNCHDARKLY_ACCESS_TOKEN = "<LAUNCHDARKLY_ACCESS_TOKEN>"
> $env:LAUNCHDARKLY_OAUTH_TOKEN = "<LAUNCHDARKLY_OAUTH_TOKEN>"

Configuration Options

Use pulumi config set launchdarkly:<option> or pass options to the constructor of new launchdarkly.Provider.