1. Packages
  2. Linode
  3. API Docs
  4. getLkeVersions
Linode v4.7.0 published on Friday, Sep 29, 2023 by Pulumi

linode.getLkeVersions

Explore with Pulumi AI

linode logo
Linode v4.7.0 published on Friday, Sep 29, 2023 by Pulumi

    Provides details about the Kubernetes versions available for deployment to a Kubernetes cluster.

    Example Usage

    The following example shows how one might use this data source to access information about a Linode LKE Version.

    using System.Collections.Generic;
    using System.Linq;
    using Pulumi;
    using Linode = Pulumi.Linode;
    
    return await Deployment.RunAsync(() => 
    {
        var example = Linode.GetLkeVersions.Invoke();
    
    });
    
    package main
    
    import (
    	"github.com/pulumi/pulumi-linode/sdk/v4/go/linode"
    	"github.com/pulumi/pulumi/sdk/v3/go/pulumi"
    )
    
    func main() {
    	pulumi.Run(func(ctx *pulumi.Context) error {
    		_, err := linode.GetLkeVersions(ctx, nil, nil)
    		if err != nil {
    			return err
    		}
    		return nil
    	})
    }
    
    package generated_program;
    
    import com.pulumi.Context;
    import com.pulumi.Pulumi;
    import com.pulumi.core.Output;
    import com.pulumi.linode.LinodeFunctions;
    import java.util.List;
    import java.util.ArrayList;
    import java.util.Map;
    import java.io.File;
    import java.nio.file.Files;
    import java.nio.file.Paths;
    
    public class App {
        public static void main(String[] args) {
            Pulumi.run(App::stack);
        }
    
        public static void stack(Context ctx) {
            final var example = LinodeFunctions.getLkeVersions();
    
        }
    }
    
    import pulumi
    import pulumi_linode as linode
    
    example = linode.get_lke_versions()
    
    import * as pulumi from "@pulumi/pulumi";
    import * as linode from "@pulumi/linode";
    
    const example = linode.getLkeVersions({});
    
    variables:
      example:
        fn::invoke:
          Function: linode:getLkeVersions
          Arguments: {}
    

    Using getLkeVersions

    function getLkeVersions(opts?: InvokeOptions): Promise<GetLkeVersionsResult>
    def get_lke_versions(opts: Optional[InvokeOptions] = None) -> GetLkeVersionsResult
    func GetLkeVersions(ctx *Context, opts ...InvokeOption) (*GetLkeVersionsResult, error)

    > Note: This function is named GetLkeVersions in the Go SDK.

    public static class GetLkeVersions 
    {
        public static Task<GetLkeVersionsResult> InvokeAsync(InvokeOptions? opts = null)
    }
    public static CompletableFuture<GetLkeVersionsResult> getLkeVersions(InvokeOptions options)
    // Output-based functions aren't available in Java yet
    
    fn::invoke:
      function: linode:index/getLkeVersions:getLkeVersions
      arguments:
        # arguments dictionary

    getLkeVersions Result

    The following output properties are available:

    Id string

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    Versions List<GetLkeVersionsVersion>
    Id string

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    Versions []GetLkeVersionsVersion
    id String

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    versions List<GetLkeVersionsVersion>
    id string

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    versions GetLkeVersionsVersion[]
    id str

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    versions Sequence[GetLkeVersionsVersion]
    id String

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    versions List<Property Map>

    Supporting Types

    GetLkeVersionsVersion

    Id string

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    Id string

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    id String

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    id string

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    id str

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    id String

    The Kubernetes version numbers available for deployment to a Kubernetes cluster in the format of [major].[minor], and the latest supported patch version.

    Package Details

    Repository
    Linode pulumi/pulumi-linode
    License
    Apache-2.0
    Notes

    This Pulumi package is based on the linode Terraform Provider.

    linode logo
    Linode v4.7.0 published on Friday, Sep 29, 2023 by Pulumi